It is currently November 25, 2017, 4:32 am.

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: November 17, 2017, 11:23 am 
Offline
User avatar

Joined: June 1, 2009, 9:28 pm
Posts: 879
Location: Cambridge Springs, PA
National Flag: United States of America
Didn't see a category for other Fords, so I figured I'd post it here. Got a 2001 Ford F150 5.4 with about 140,000 miles on it. Recently its started to act up at idle. This usually happens when I am at a stoplight. Will idle erratically and sometimes dies. While I'm driving I haven't noticed an issue. Today it seemed to stumble while accelerating from a stop. And it did this today every time i had to stop and start again while at a light.

It previously had the check engine light come on about a week ago and got these codes: P0171 (System too Lean Bank 1) and P0174 (System too Lean Bank 2).

So far i have replaced the pcv valve and tubing, and cleaned the mass air flow sensor. Still has the same issue. Any ideas? Maybe a fuel filter?

Thanks guys for the help.

Duke

_________________
The Green Machine

GO ARMY, BEAT NAVY!


Top
 Profile  
Reply with quote  
PostPosted: November 17, 2017, 4:58 pm 
Offline
User avatar

Joined: October 14, 2006, 6:16 pm
Posts: 9050
Images: 125
Location: In the shed... Cranebrook NSW
National Flag: Australia
Have you checked the throttle body bushings for the butterfly.... thats my stab in the dark Matt !... and why are you idling anyhow ? :P

_________________
Honey, If I say I`ll fix something I will, there`s no need to remind me every 6 months!!


66 f100 tabletop swb 351 Clevo C6 "Beryl"


Top
 Profile Personal album  
Reply with quote  
PostPosted: November 17, 2017, 5:42 pm 
Offline

Joined: November 8, 2013, 1:20 am
Posts: 299
Location: Edmonton, Alberta
National Flag: Canada
Check fuel pressure at the rail.

When was the last fuel filter change?


Top
 Profile  
Reply with quote  
PostPosted: November 17, 2017, 8:47 pm 
Offline
User avatar

Joined: October 5, 2012, 5:29 am
Posts: 605
Images: 0
Location: Montgomery NY
National Flag: United States of America
I would first check for vacuum leaks. Then fuel filter.

_________________
'63 F100 223 3OT
'94 F150 300 E4OD


Top
 Profile Personal album  
Reply with quote  
PostPosted: November 18, 2017, 12:55 am 
Offline

Joined: February 15, 2011, 10:32 am
Posts: 1490
Images: 6
Location: Edmonton, Alberta
National Flag: Canada
A couple that come to mind.....
Dirty IAC (Idle Air Controller) Google it, pretty easy to clean

Bad TPS (Throttle Position Sensor) (but it should be throwing a code for this one)


Top
 Profile Personal album  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group